Newsbreak

Sanders hits “establishment” Planned Parenthood for endorsing Clinton

Planned Parenthood’s endorsement of Democratic front-runner Hillary Clinton for president has led to a small war of words between the abortion giant and Clinton’s competitor for the party nomination, socialist Vermont Senator Bernie Sanders.

On Tuesday, Sanders told MSNBC’s Rachel Maddow that he was running to “tak[e] on not only Wall Street and the economic establishment, we’re taking on the political establishment,” then said that Planned Parenthood (among other groups) had endorsed the former First Lady instead of him because “Hillary Clinton has been around there for a very, very long time and some of these groups are, in fact, part of the establishment.”

The next day, Clinton and Planned Parenthood both issued tweets criticizing the statement:

As recounted by The Blaze and Twitchy, numerous supporters of both candidates reacted to the tweets with indignation, with some Sanders supporters alleging that by endorsing Clinton, Planned Parenthood had put her prominence ahead of their members’ preferences for who should be the next president. Live Action News has also reported on Planned Parenthood supporters disappointed by their decision.

Both Sanders and Clinton hold 100% ratings with Planned Parenthood, and both have been vocal defenders of the abortion giant following the release of undercover videos revealing their sale of organs from aborted babies.

What is Live Action News?

Live Action News is pro-life news and commentary from a pro-life perspective. Learn More

Corrections or Questions

For corrections, or questions, please contact the editor at [email protected]

GUEST ARTICLES: To submit a guest article to Live Action News, email [email protected] with an attached Word document of 800-1000 words. Please also attach any photos relevant to your submission if applicable. If your submission is accepted for publication, you will be notified within three weeks. Thank you for your interest in Live Action News!



To Top
[if lte IE 8]
[if lte IE 8]